Crypto F200 ADSL USB Modem σε Linux (Ubuntu Feisty Fawn)

f200.jpgcervo.gif
To F200 ήρθε πακέτο με το ADSL in a box της Forthnet πριν μερικούς μήνες. Η αλήθεια είναι ότι την πρώτη φορά με παίδεψε αρκέτα μέχρι να δουλέψει, οπότε με την ευκαιρία της επανεγκατάστασης του σε Ubuntu 7.04 (Feisty Fawn) είπα να γράψω αυτόν το σύντομο οδηγό.

Καταρχήν θα χρειαστείτε τα εξής:

  1. Τον driver του modem από την σελίδα του κατασκευαστή (ή εναλλακτικά από το φάκελο /driver/Wan/ του συνοδευτικού cd). Κρατήστε το αρχείο CnxEtu.sys
  2. Από το πακέτο κρατήστε το αρχείο cxacru-fw.c
  3. Αν δεν το κάνατε ήδη, εγκαταστήστε το πακέτο build-essential από το cd της διανομής (χρησιμοποιήστε τον Synaptic Package Manager από το μενού System>Administration)

Ανοίξτε μία κονσόλα (Applications>Accessories>Terminal) και δώστε τις παρακάτω εντολές:

  1. Πήγαινετε στον φάκελο που έχετε τα παραπάνω δύο αρχείο (πχ. cd Desktop αν είναι στην επιφάνεια εργασίας)
  2. Καντε compile το εργαλείο: gcc -o cxacru cxacru-fw.c
  3. Δώστε δικαιώματα εκτέλεσης στο αρχείο που προκείπτει: chmod +x cxacru
  4. Εκτελέστε: ./cxacru CnxEtU.sys cxacru-fw.bin
  5. Αντιγράψτε το αρχείο στον εξής φάκελο: sudo cp cxacru-fw.bin /lib/firmware/2.6.20-15-generic/ (σε περίπτωση που έχετε άλλη διανομή ψάξτε να βρείτε τον αντίστοιχο φάκελο firmware με την εντολή: locate firmware)
  6. Στο σημείο αυτό κάντε restart το σύστημα σας.

Τώρα ο driver του μόντεμ πρέπει να λειτουργεί κανονικά. Το φωτάκι του μόντεμ αναβοσβήνει και όταν το μόντεμ συγχρονιστεί μένει σταθερά αναμμένο. Οπότε μένει να φτιάξουμε της ρυθμίσεις της σύνδεσης. Ανοίξτε πάλι μία κονσόλα.

  1. Δημιουργήστε ένα αρχείο με το όνομα του ISP(πχ. forthnet) σας. Όταν σας ζητηθεί δώστε το password του root στο σύστημα σας: sudo gedit /etc/ppp/peers/forthnet
    και αντιγράψτε τα εξής:
    lcp-echo-failure 3
    noipdefault
    defaultroute
    #nb put your username and isp in the following line
    user "ΌνομαΧρήστη"
    noauth
    noaccomp
    nopcomp
    noccp
    novj
    holdoff 4
    persist
    maxfail 25
    updetach
    usepeerdns
    #nb pppOE users put plugin pppOE for the next line
    plugin pppoatm.so
    #nb instead of 0.00* put your vpi.vci (if you are using pppOATM) (pppOE users put nas0)
    8.35

    όπου ΌνομαΧρήστη το username σας(πχ. user.ath.forthnet.gr@forthnet.gr). Σώστε το αρχείο και κλείστε το gedit.
  2. Ανοίξτε το αρχείό: sudo gedit /etc/ppp/pap-secrets
    Και προσθέστε στο τέλος την γραμμή:
    "ΌνομαΧρήστη" "*" "ΚωδικόΧρηστη"
    όπου ΌνομαΧρήστη το όνομα που χρησιμοποιήσατε και πρίν και ΚωδικόςΧρήστη ο κωδικός της συνδεσής σας.

Πλέον μπορείτε να συνδεθείτε στο internet με την εντολή:
sudo pon forthnet
ή να αποσυνδεθείται με την εντολή:
sudo poff forthnet

Για δική σας ευκολία μπορείτε να φτιάξετε μια συντόμευση με τον εξής τρόπο:

  1. Κάντε δεξί κλικ στο Panel και επιλέξτε Add To Panel
  2. Πατήστε το κουμπί Custom Application Launcher και συμπληρώστε όπως στην εικόναforthnet.png
    Κάθε φορά που θέλετε να συνδεθείτε πατάτε την συντόμευση που δημιουργήσατε και δίνετε τον κωδικό του root. Με τον ίδιο τρόπο μπορείτε να φτιάξετε και συντόμευση για αποσύνδεση αλλά μάλλον κάτι τέτοιο είναι άχρηστο.

edit(8/5/07): Επειδή αναφέρθηκαν προβλήματα(από τον φίλο Leo τον οποίο και ευχαριστώ) με το αρχειάκι CnxEtU.sys που υπάρχει στους διαθέσιμους για κατέβασμα driver απο την Crypto, να αναφέρω ότι το αρχείο μπορείτε να το κατεβάσετε και από εδώ μαζί με το cxacru-fw.bin.

edit(10/6/08): Δείτε και εδώ. Δεν το έχω δοκιμάσει αλλά ίσως βοηθήσει…

[ref1, ref2, ref3,ref4,ref5]

Advertisements

78 thoughts on “Crypto F200 ADSL USB Modem σε Linux (Ubuntu Feisty Fawn)

  1. Τι σφάλμα σου βγάζει; Δοκίμασε καλού κακού το CnxEtU.sys από το cd που ήρθε μαζί με το μόντεμ. Νομίζω ένα από τα διαθέσιμα version για κατέβασμα από το site της crypto δεν μου έπαιζε ούτε εμένα.

  2. Αυτό χρησιμοποίησα από το CD. Το σφάλμα που μου βγάζει είναι:
    Segmentation fault (core dumped)

    Μήπως θα σου ήταν εύκολο να μου στείλεις έτοιμο το cxacru-fw.bin στο e-mail μου (*****@yahoo.gr). Σου διευκρινίζω ότι έχω ακριβώς το ίδιο modem και Linux (Ubuntu 7.04 Feisty Fawn) σε AMD 64 3000+.

    Ευχαριστώ εκ των προτέρων για το ενδιαφέρον.

  3. Α! Επίσης όταν έκανα install από το Synaptics Package Manager του build-essential δυσκολεύτηκα να το βρω στο cd του installation και έχω αμφιβολία για το κατα πόσο έχω κάνει σωστή δουλειά. Πάντως, όταν έλεγξα τη λίστα το είδα το πακέτο και το έδινε οκ. Αν έχεις κάτι συγκεκριμένο και γι’ αυτό θα με βοηθούσες πολύ. Ευχαριστώ και πάλι.

  4. Εγώ δουλεύω ακόμα στα 32μπιτ οπότε μάλλον δεν κάνει το δικό μου binary(θα στο στείλω πάντως). Θα δω πάλι την διαδικασία το βράδυ στο σπίτι(εδώ δεν έχω το μόντεμ) και θα σου απαντήσω. Πάντως δοκίμασε με διαφορετικές εκδόσεις του CnxEtU.sys από το site της crypto ίσως κάποιες πιο καινούργιες δεν είναι συμβατές με το cxacru (ίσως πάλι λέω και βλακείες)…
    Όσον αφορά το δεύτερο αν κάτι δεν είχε εγκατασταθεί σωστά υποθέτω οτί δεν θα σου έφτιαχνε το εκτελέσιμο cxacru.

  5. Δοκίμασα και με τα τρια drivers που δίνει το site. Το καλύτερο που πήρα ήταν το δεύτερο που μου δίνει error:
    ./cxacru firmware start sequence not found
    ./cxacru can’t find AccessRunner firmware in CnxEtU.sys

    μαζί αυτά. Ελπίζω να δουλέψει το δικό σου. Ευχαριστώ, το περιμένω.

  6. Σου έστειλα mail. Καλή τύχη!
    Όποιος άλλος ενδιαφέρετε μπορεί να κατεβάσει τα αρχεία .sys και .bin από εδώ.

  7. Έκανα όλη την διαδικασία με το δικό σου binary και έχω φτάσει εδώ:
    leonidas@leonidas-desktop:~$ sudo pon tellas

    Plugin pppoatm.so loaded.

    Using interface ppp0

    Connect: ppp0 8.35

    PAP authentication succeeded

    Cannot determine ethernet address for proxy ARP

    local IP address 84.254.23.62

    remote IP address 62.169.255.68

    primary DNS address 62.169.194.17

    secondary DNS address 62.169.194.18

    σου λέει τίποτα;
    το μόντεμ λειτουργεί (λαμπάκι σταθερό) αλλά όχι διαδίκτυο κλπ.

  8. Είσαι σε καλό δρόμο. Κάτι παίζει με τα options που χρησιμοποιώ στο /etc/ppp/peers/forthnet. Μάλλον χρειάζεται κάτι διαφορετικό για την tellas. Τα διαθέσιμα options μπορείς να τα δεις στο /etc/ppp/options. Δεν έχω ιδέα τι μπορεί να είναι. Δες τις αντίστοιχες ρυθμίσεις όταν παίζεις σε windows μήπως βγάλεις άκρη και αυτό μήπως πάρεις καμία ιδέα. Αν θες στείλε κανένα mail στην λίστα linux-greek-users σίγουρα θα βρεις κάποιον με περισσότερες γνώσεις από εμένα να σου απαντήσει.

  9. Εντάξει το είδα, το απόγευμα θα δοκιμάσω και θα σε ενημερώσω. Ευχαριστώ. Ξέρεις δεν βοηθά καθόλου το ότι δεν έχω προγραμματίσει ξανά (εκτός από basic παλαιότερα) και τώρα είναι τα πρώτα μου βήματα στα Linux, οπότε όταν στην σελίδα που μου έδωσες λέει για make και διάφορα άλλα, δυσκολεύομαι πολύ να εφαρμόσω. Κάνω πολλά λάθη και τελικά βρίσκω την άκρη αλλά δύσκολα. Μήπως να βάλω άλλο version των Linux; Είσαι πολύ εξυπηρετικός ωστόσο, σ’ευχαριστώ!

  10. Νομίζω ότι το ubuntu είναι ότι καλύτερο για αρχή(και όχι μόνο) αυτή τη στιγμή και έχει πολύ καλό support για νέους χρήστες(βλέπε UbuntuForums, UbuntuGuide κλπ). Στην σελίδα που σου έδωσα δοκίμασε απλά τα options που δίνει στο /etc/ppp/options μήπως κάτι από αυτά σου δουλέψει. Δεν νομίζω ότι χρειάζεται να ασχοληθείς με make κλπ. Δυστυχώς δεν έχω tellas οπότε δεν μπορώ να βοηθήσω περισσότερο. Πάντως κάνε έναν κόπο και στείλε ένα mail στη λίστα που σου έδωσα. Εξήγησε τους τι έχεις κάνει μέχρι τώρα και το αποτέλεσμα που έχεις. Δεν είσαι μακρυά από το να δουλέψει πάντως. Ο driver πλέον παίζει ok το θέμα είναι τώρα οι ρυθμίσεις τις σύνδεσης. Στείλε και κανένα mail στο support της tellas ίσως μπορούν να σε βοηθήσουν αν και δεν νομίζω να παρέχουν επίσημα υποστήριξη για linux. Όσον αφορά το πόσο εξυπηρετικός είμαι, μην ξεχνάς ότι με βοηθάς και εσύ να βελτιώσω το how-to.

  11. Όλα οκ, όντως χρειαζόταν μια δυο σειρές αλλαγή στο options και αμέσως δούλεψε! Τέλεια! Το e-mail μου είναι πάντα στην διάθεσή σου. Σου σημειώνω ότι χρησιμοποίησα το δικό σου binary.

  12. Υπερευχαριστώ, χωρίς δίκτυο δεν μπορούσα να πετάξω τα Windows. Τώρα είναι παρελθόν…Λεωνίδας

  13. Αν θες πόσταρε το τελικό /etc/ppp/tellas όπως σου δούλεψε για να μην παιδευτούν και οι επόμενοι που θα προσπαθήσουν να σετάρουν το μόντεμ με tellas.
    ΥΓ.Χαίρομαι που ακόμα ένας χρήστης πέταξε τα Windows. Counter++

  14. Βασικά έκανα τα εξής:

    1)Ότι γράφεις εσύ εδώ
    2)στο etc/ppp/options:
    lock
    defaultroute
    noipdefault
    noaccomp
    nopcomp
    noccp
    novj
    holdoff 4
    persist
    maxfail 25
    usepeerdns
    passive
    asyncmap 0
    lcp-echo-interval 2
    lcp-echo-failure 7
    nameusername
    user username
    3)Πρόσθεσα και στο /etc/ppp/chap-secrets ως τελευταία γραμμή το:
    “username” “*” “password”

    και μετά δούλεψε το μόντεμ….

    Αν το cxacru-fw.bin δεν σας δουλέψει, απλώς ζητήστε το από κάποιον και ακουλουθήστε την διαδικασία.

  15. Γεια σας παιδία.Έχω το ίδιο modem και δοκίμασα αυτα που είπατε αλλα τίποτα μου βγάζει σφάλμα στην εντολή αυτή ./cxacru CnxEtU.sys cxacru-fw.bin .Pls help!!!!

  16. Αν μπορείς πες αναλυτικά τι σφάλμα σου βγάζει. Εναλλακτικά χρησιμοποίησε το .bin από εδώ και συνέχισε τη διαδικασία από το επόμενο βήμα(5).

  17. Για να εγκαταστησω το μοντεμ τησ crypto(F200) σε zenwalk διανομη,ακολουθω τα ιδια βηματα η θα τα βρω μπαστουνια?

  18. Λογικά τα βασικά βήματα είναι ίδια. Δεν έχω δουλέψει τη συγκεκριμένη διανομή για να σου πω αν έχει κάποια ιδιαιτερότητα.

  19. ΑΝΤΩΝΗ ΚΑΛΗΣΠΕΡΑ.ΕΧΩ ΠΡΟΒΛΗΜΑ ΜΕ ΤΟΥΣ DRIVERS ΤΟΥ CRYPTO F200 .ΔΕΝ ΜΠΟΡΩ ΝΑ ΤΟΥΣ ΒΑΛΩ ΣΤΟ UBUNTU.Ο ΛΟΓΟΣ ΕΙΝΑΙ ΟΤΙ ΜΟΥ ΒΓΑΖΕΙ ΤΟ ΕΞΗΣ ΛΑΘΟΣ ΤΟ TERMINAL:ΟΤΑΝ ΒΑΖΩ ΤΗΝ ΕΝΤΟΛΗ gcc -o cxacru cxacru-fw.c ΜΟΥ ΛΕΕΙ COMMANT NOT FOUND.KATI KAΝΩ ΛΑΘΟΣ ΕΓΩ ΣΙΓΟΥΡΑ.ΕΧΩ ΚΑΤΕΒΑΣΕΙ ΣΤΗΝ ΕΠΙΦΑΝΕΙΑ ΕΡΓΑΣΕΙΑΣ ΟΛΟΥΣ ΤΟΥΣ DRIVERS ΠΟΥ ΠΡΕΠΕΙ ΑΛΛΑ ΔΕΝ ΜΠΟΡΩ ΝΑ ΤΟΥΣ ΠΑΩ ΣΤΟ ΣΥΣΤΗΜΑ.ΤΙ ΑΚΡΙΒΩΣ ΠΡΕΠΕΙ ΝΑ ΚΑΝΩ ΠΕΣ ΜΟΥ.ΕΙΜΑΙ ΑΡΧΑΡΙΟΣ ΣΤΟ UBUNTU ΓΙ ΑΥΤΟ ΚΑΙ ΘΕΛΩ ΛΕΠΤΟΜΕΡΕΣ ΤΙΣ ΕΝΤΟΛΕΣ ΑΝ ΜΠΟΡΕΙΣ.ΜΑΛΛΟΝ ΔΕΝ ΓΡΑΦΩ ΤΙΣ ΕΝΤΟΛΕΣ ΣΩΣΤΑ Η ΔΕΝ ΒΛΕΠΕΙ ΠΟΥ ΕΧΩ ΒΑΛΕΙ ΤΟΥΣ DRIVERS.EYXARISTV EK TVN PROTERVN

    Τάκη, λογικά δεν έχει εγκαταστήσει τον gcc (βλέπε βήμα 3: build-essential). Αν δεν μπορείς να βρεις το πακέτο αυτό στο CD της διανομής σου ή να το κατεβάσεις, παρέκαμψε αυτό το βήμα και κατέβασε απευθείας αυτό. Κρατάς το αρχείο cxacru-fw.bin και συνεχίζεις από το βήμα 5:
    sudo cp cxacru-fw.bin /lib/firmware/2.6.20-15-generic/

  20. Ok ta katafera.POLY xrhsimos odhgos. To lathos pou ekana egw htan oti evaza ” ” sta pap/chap secrets.Geloio men, la8os de,Syggnwmh gia ta greeklish molis mphka kai den exw kanei tpt akomh,

  21. Καλές οι οδηγίες, αν και όταν έκανα εγκατάσταση το ubuntu είχα πρόβλημα με το gcc (δεν έβρισκε τις βιβλιοθήκες), χάρι όμως στα δικά σου έτοιμα αρχεία συνέχισα από το βήμα 5.
    Προσοχή στα εισαγωγικά(“”). Μέχρι να καταλάβω ότι στα αρχεία που έκανα edit δεν γραφόταν σωστά οι χαρακτήρες εισαγωγικών, δε μου δούλεψε.
    Μια άσχετη ερώτηση: Πως ρυθμίζουμε το firewall με το Crypto?

  22. Νομίζω ότι αν εγκαταστήσεις το build-essential πακέτο δεν έχει πρόβλημα με τον gcc,… ελπίζω να μην ξεχνάω κάτι άλλο. Με τα εισαγωγικά γίνεται όντως μια βλακία στη μορφοποίηση…και χαλάνε στο copy-paste:(
    Δεν χρειάζεται κάτι το ιδιαίτερο για το crypto νομίζω. Εγκατέστησε ένα απλό firewall (εμένα με έχει βολέψει το guarddog που έχει αρκετά εύχρηστο γραφικό περιβάλλον)

  23. file antoni se efxaristo poly. eimai asxetos apo entoles se linux kai eftyxos tin vrika tin akri me ton odigo sou. thenx kai pali thenx.

  24. παιδιά και εγώ μόλις εγκατέστησα με τον οδηγό το firmware μπραβο Αντώνη για τις οδηγίες.Το modem το δουλεύω εδώ και ένα χρόνο αλλά έπερνα το firmware απο τα win.Nα προσθέσω μόνο ότι αν έχετε κάνει update στον kernel η εντολή
    sudo cp cxacru-fw.bin /lib/firmware/2.6.20-15-generic/
    μπορεί να είναι
    sudo cp cxacru-fw.bin /lib/firmware/2.6.20-16-generic/
    δλδ ανάλογα με τον kenrel που έχετε.

  25. @chech2fire: Ευχαριστώ για τα καλά σου λόγια και για την διευκρίνιση όσον αφορά το kernel version.
    @chris: counter++

  26. polu xrhsimos odhgos file na sai kala…to thema einai oti enw leitourgouse kanonika kapoia stigmh stamathse na mou anagnwrizei th suskeuh..skefthka oti ftaiei to update se 2.6.20-16-generic kai antegrapsa to cxacru-fw.bin /lib/firmware/2.6.20-16-generic/ alla den ginetai tipota..

    to error pou mou bgazei einai : 8.35(no such device)

  27. telika ok egine to thema enw eixa kanei restart den eixe ginei thn prwth fora alla th deuterh..kai pali thanks gia ton odhgo.

  28. γεια σασ παιδια. εχο το crypto f200 και δεν μπορω να κατεβασω ουτε ταινιεσ ουτε τραγουδια,τιποτα. δεν συνδεεται καν με τους trakers. μηποσ εχετε καμια λυση???

  29. Plugin pppoatm.so loaded.
    Using interface ppp0
    Connect: ppp0 8.35
    PAP authentication failed.

    Kai de mporo na katalavo to giati. Pao akribos me ton odigo.

  30. @johny: File apo oti 8imame to ixa parei apla apo to site tis forthnet:P
    @ParadiseSoul: Kati kaneis la8os me tus kodikus su sto pap-secrets, prosexe ta eisagwgika opws ipe kai o mitsos

  31. Πολύ κατατοπιστικός ο οδηγός για την εγκατάσταση του crypto. Πολύ εύκολα κατάφερα και εγκατέστησα τους drivers με την διαδικασία που περιγράφεις (χωρίς να έχω ιδέα από Linux καθώς τώρα ξεκινάω). Το πρόβλημά μου είναι πως δεν μπορώ να φτιάξω σύνδεση. Στα win συνδέομαι με PPPoE και παραμέτρους 8.35 μέσω Teledome. Plugin pppoe.so δεν υπάρχει εγκατεστημένο στο σύστημά μου έτσι δοκίμασα με pppoatm (δεν ξέρω αν έτσι δουλεύει..). Το μήνυμα που λαμβάνω είναι το ακόλουθο:

    Plugin pppoatm.so loaded.
    Using interface ppp0
    Connect: ppp0 8.35
    LCP: timeout sending Config-Requests

    Μήπως κάποιος έχει κάτι να προτείνει?

  32. καλησπερα στην παρέα σας. Θέλω επιτέλους ν απαλλαγώ απ’ τα win κ επέλεξα ubuntu. Το πρόβλημά μου είναι με το crypto f200. Έκανα ό,τι λες στον οδηγό + το ότι πρόσθεσα αυτά που γράφει ο Leo αλλά μάλλον κάνω λάθος με τα εισαγωγικά. Ποια είναι τα σωστά? Τα μονά ή τα διπλά? Δηλ 2 φορές πατάω μονά η με Shift τα διπλά? ιατί τρέχοντας την sudo pon tellas μου βγάζει αυτό το μύνημα
    max@max0300: /usr/sbin/ppd: in the file /etc/ppp/peers/tellas: unrecognized option ‘max’

    Όπου Linux user to max k isp user to max0300@tellas.gr. ΒΟΗΘΕΙΑ

  33. re paidia emena otan bazw thn entolh sudo cp cxacru-fw.bin /lib/firmware/2.6.20-15-generic/
    mou bgazei sto terminal ta e3hs:
    cp: cannot stat ‘cxacru-fw.bin’ : no such file or directory
    ti na kanw?

  34. Kalhspera..
    Exw kai egw to idio problhma me ton LEO..

    “Cannot determine ethernet address for proxy ARP”

    Anabei to fwtaki alla den exei internet..Prospa8hsa na kanw ta alla bhmata pou lei apo katw alla xwris tuxh..

    Mhpws kapoios eluse auto to problhma?

    Efxaristw!

  35. Les “Από το πακέτο κρατήστε το αρχείο cxacru-fw.c”
    paketo ennoeis ton driver tou F200??
    an nai, den uparxei mesa kapoio tetoio arxeio..
    Telika pou to vriskw to cxacru-fw.c???

    Euxaristw!

  36. Geia sas,
    kanw th diadikasia egkatastashs k sindeshs tou modem k otan pataw thn entolh sudo pon forthnet(onoma sindeshs)mou vgazei sthn konsola:

    Plugin pppoatm.so loaded.
    Using interface ppp0
    Connect: ppp0 8.35
    LCP: timeout sending Config-Requests
    Connection terminated
    modem hang up

    kai pali apo thn 2h-using… ws thn 6h-modem hang up.
    kserei kanei tpt??
    eida oti k o beetle liga sxolia parapanw exei to idio problem alla den pire apanthsh
    THANKS

  37. Γεια σας, παιδία!
    Έχω πρόβλημα με το driver για το F201. Νομίζω το F200 είναι για ISDN, ενώ το F201 – PSTN.
    Έκανα την δωρεάν σύνδεση από το RAM. (ALTEC , και PSTN). Ακολουθώντας τα βήματα που έχετε αναφέρει με τα αρχεία παραπάνω δεν κατάφερα να «ανάψω » το λαμπάκι του modem! Προσπάθησα να χρησιμοποιήσω το gwausb.sys από το CD του modem – δεν περνάει το compile – χτυπάει “… firmware start sequence not found”… Πριν το compile άλλαζα το όνομα του «gwausb.sys» σε «CnxEtU.sys»…
    Έχω το Linux Ubuntu 7.10…
    Ευχαριστώ για οτιδήποτε βοήθεια, πληροφορία….

  38. Geia sas. Exw parei ta 2 arxeiakia pou lete stin arxi stis odigies. Ektelw tin entoli gcc -o cxacru cxacru-fw.c kai petaei san errors oles tis vivlio8ikes pou exoun ginei include ka8ws kai ,;/ . Den tis anagnwrizei. Ti na kanw??

  39. @Eleni: …εγκαταστήστε το πακέτο build-essential… λογικά είναι μέσα στο cd της διανομής
    @iant: ΤοF200 βγαίνει σίγουρα και για pstn, Λογικά το F201 είναι πιο καινούργια έκδοση,… που θέλει και άλλους drivers.
    @george: Δεν ξέρω τι άκριβως φταίει και είμαι μακρυά από το linuxάκι μου γιανα το ψάξω περισότερο:(

  40. @antonis:
    ΤοF200 βγαίνει σίγουρα και για pstn, Λογικά το F201 είναι πιο καινούργια έκδοση,… που θέλει και άλλους drivers.

    Σίγουρα! Είχα βρει και στο CD του και στο σκληρό μου τα .sys!
    Ηταν και σε μέγεθος διαφορετικά από το “CnxEtU.sys”!
    Μάλλον χρειάζεται να γραφτεί νέο “cxacru-fw.c”….

  41. Έχετε καμμιά ιδέα άν παίζει σε conn-x 768 (BAUDTEC C802USΒ-Α0); Το θέλει ένας φίλος μου….

  42. ./cxacru CnxEtU.sys cxacru-fw.bin
    Meta to error message :
    found firmware in `CnxEtU.sys’ at offset 0x7180

    Αυτό σου βγάζει; Και σε μένα!!!!
    Τι να κάνεις;;;;!!!!
    Εγώ προσωρινά βγαίνω στο internet από τα XP. Αλλά ψάχνω για κανένα router με SPI firewall για να βρω την ησυχία μου!

    Πάντως, και με XP το Crypto F201 μου έκανε νερά…
    Επομένως ποτέ ξανά Crypto και οτιδήποτε σε Conexant chipset!!!

  43. το μοντεμ συγχρονιστηκε… Εχω εκτελεσει οτι λέτε πιο πανω. Οταν ομως γραψω sudo pon forthnet μου βγάζει τα εξης:

    Plugin pppoatm.so loaded.
    Using interface ppp0
    Connect: ppp0 8.35
    Remote message: Bad Password
    PAP authentication failed
    Connection terminated.

    Τι κάνω λάθος??

  44. to username kai to password sot pap-secrets ta xw valei swsta… Sto arxeio chap-secrets ti prepei na periexetai?

    Eyxaristw ek twn proterwn

  45. Τελικά κατάφερα να δω το «φως» από το Linux !
    Αλλά με το μοδεμάκι BaudTec (ένας φίλος μου το έδωσε). Νομίζω πρέπει να είναι το ίδιο με το F200!
    Είχα στο CD του αρχείο CnxEtu.sys !
    Λοιπόν, με τις οδηγίες του «antonis» στο Ubuntu 7.10 εγκαθιστά μια χαρά!
    Μόνο βγάζουμε τα αυτάκια από user “ΌνομαΧρήστη“ και “ΌνομαΧρήστη” “*” “ΚωδικόΧρηστη“. Στο δεύτερο γράφουμε διαχωρίζοντας με TAB-χαρακτήρα .
    Δηλαδή : enas@layalaya[TAB-χαρακτήρα]*[TAB-χαρακτήρα]Κωδικό Χρήστη

    Στο Kubuntu 7.10 χρειάστηκε να παρεμβω και στα αρχεία που αναγράφει «Leo» παραπάνω !
    Δηλαδή στα etc/ppp/options και /etc/ppp/chap-secrets.
    Restart !!! Και …. ΤΕΛΟΣ ΤΑΛΑΙΠΩΡΙΑΣ !!!!

    P.S. Επειδή δεν έπαιζε στο Kubuntu sudo gedit έκανα αντιγραφεί στο NTFS δίσκο (Windows) μετά copy (Ctrl+C) στο /Home/Descktop . Εκεί έκανα αλλαγές και
    μετά με sudo cp όνομα_αρχείου etc/ppp/όνομα_αρχείου πίσω στη θέση τους!!!

  46. Ρε παιδια help.Εκανα ολεσ τισ διαδικασιες κανονικα αλλα μου βγαζει το προβλημα σα του παλικαριου που ειχε τελλας και η8ελε αλλες ρυθμισεις εγω ομως εχω οτενετ!καμια ιδεα?
    Pap aythentication succeeded
    Cannot determine ethernet adress for proxy arp

  47. Έχω ακολουθήσει τον οδηγό που αναφερεται πιο πανω κατα γραμμα και προσπαθήσω να ενωθώ στο internet βγάζει αυτό:

    Plugin pppoatm.so loaded.
    Using interface ppp0
    Connect: ppp0 8.35
    PAP authentication failed.

    Έχω προσθέσει τα απαραίτητα στα pap-secrets και chap-secrets. Καμμιά ιδέα κανείς???

    Πόσο δύσκολο είναι πια να κανεις ενα απλό connect???

    Ελέος….

  48. Έχω ελέγξει και τα εισαγωγικα και πάλι βγαζει το ίδιο πράγμα…
    Τί αλλο μένει να κάνω???

  49. γεια χαρα παιδία κ εγω είμαι ενας ακομα που προσπαταθει να ξεφύγει απο τα καταραμένα windows αλλά δεν… λοιπον έχω κ εγώ tellas, ακολουθόντας βήμα βήμα τον leo μου πετάει error στο /etc/ppp/options στην γραμή που λέει “nameusername” αν μπορει να βοηθίσει κάποιος 🙂

  50. to “DreamTraveler”
    Δοκίμασε έτσι :
    #nameusername
    #user username
    Πάντως σε μένα σε Kubuntu έτσι έπαιξε!
    Μετα απο αυτο και restart χρειάστηκε στις ριθμισεις δυκτιου σε ενα σημιο να διαγράψω το “0.0.0.0” ( έδειχνε στο try εικονίδιο αποσυνδεδεμένου καλωδίου) !! Αυτό ήταν όλο !!!

  51. Ξέρει κανείς τι πρέπει να κανω για να βλέπει ότι είμαι μέσα?Ενώ τα έκανα όλα κανονικά πάω να κατεβάσω τους δριωερ που λέει και μετά κάνει ότι θέλω σύνδεση στο ιντερνετ για να γίνει!!!Πρέπει να κάνω κάποιο κόλπο?Έχω τα ubuntu 7.10

  52. Τα κατέβασα όλα και είναι οκ?Και αυτό από τα Ununtu στο γράφω αλλά το διόρθωσα πήγα στο synaptic package manager -> Repositories -> universe και όλα οκ!!!Αλλά γιατί ο καιρός δεν λειτουργεί και έχει ‘?’ ?

  53. γεια

    να κανω μια ερωτηση το πακετο που λες στα καταρχην δε βγαζει σε καποιο Link,ειναι απαραιτητο η δε πειραζει?

  54. Δυστυχώς δεν μπορώ να δοκιμάσω το συγκεκριμένο modem αυτή την περίοδο για να απαντήσω…

  55. γεια σας… θελω και εγω να συνδεσω το modemaki.
    αλλα επειδη εχω κατεβασει το ubuntu μεσω wubi και δεν παιζει cd… πως θα γινει να κατεβασω το built-essential??? καμια ιδεα?
    ευχαριστω … πολυ καλη δουλεια btw 🙂

  56. το ειχα κατεβασει αυτο. πηγα να το κανω εγκατασταση και μου ζητησε να βαλω cd παλι(ubuntu 7.10 gutsy) …γιατι γινεται αυτο?δεν μπορει να εγκατασταθει χωρις cd?

    ευχαριστω αντωνη για την αμεση απαντηση…καμια αλλη ιδεα? :s

  57. Ίσως αυτό βοηθήσει: http://ubuntuforums.org/showthread.php?t=251602
    Δεν έχω πλέον το συγκεκριμένο μοντεμ γιανα δοκιμάσω και να σου πω κάτι συγκεκριμένο.
    Αν δεν βγάλεις άκρη δοκίμασε να κατεβάσεις το πακετάκι που λέω στο τέλος του post (edit 8/5..) ώστε να παρακάμψεις τελείως τη διαδικασία του build και να συνεχίσεις από το βήμα 5…

  58. hello, εχω κολλησει στο βημα 3. Mε ενα αρχειο CnxEtU.sys που βρηκα στο νετ συμβαινει το εξης….
    desktop:~/Desktop$ ./cxacru CnxEtU.sys cxacru_fw.bin
    ./cxacru: firmware start sequence not found
    ./cxacru: can’t find AccessRunner firmware in
    `CnxEtU.sys’

    ενω με το cnxetu.sys απο το cd του modem το παρακατω…

    desktop:~/Desktop$ ./cxacru CnxEtU.sys cxacru_fw.bin
    ./cxacru: failed to open `cxacru_fw.bin’ for writing: File exists

    μηπως δεν ειναι σωστο το αρχειο? γιατι δεν το δεχεται?
    thanks prokatavolika:D

  59. Με κάποιες εκδόσεις του CnxEtU.sys όντως δεν παίζει η διαδικασία. Το δεύτερο error ίσως να στο πεταέι γιατί το αρχείο .bin υπάρχει είδη από τις προηγούμενες δοκιμές σου. Σβήστο και προσπάθησε πάλι με το αρχείο από το cd. Αν δεν παίξει πάρε το αρχείο από το link στο τέλος του post.
    ps.Αν θες δόσε και περισσότερες λεπτομέρειες για το πως εγκατέστησες το build-essential ώστε να υπάρχει αναφορά για τους επόμενους…

  60. antwni doulepse!!!!! katarxin eyxaristw para poli. sorry gia ta greeklish alla eimai sto linux kai akoma den exw rithmisei tipota…
    na pw oti to build-essential to evala mesw Synaptic (evala to cd tou ubuntu). apo wubi diskola na ginotan giayto ekatsa kai to egkatestisa apo to cd kanonika.
    eixes dikio ekei me to error pou elege file exists. ta esvisa ola kai ta ekana apo tin arxi me to .sys apo to cd tou modem.

    pragmatika einai o monos odigos pou evgala akri…:D:D:D
    kai pali thanks… counter++ hehe

  61. Καλή κίνηση να κάνεις κανονική εγκατάσταση,… καλό το wubi σαν ιδέα αλλά σε περιορίζει αρκετά μάλλον.
    counter++ λοιπόν:P

  62. “Δυστυχώς” δεν έχω πλέον το modem για να βοηθήσω. Αν θες πες σε πιο βήμα σου βγάζει το μήνυμα μήπως μου λέει κάτι..

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.